Simon 5.0Simon 5.0
Monitor websites and servers for changes or failures
Download
de en fr 
Simon_5.0.zip

System Require­ments: macOS 10.12 (Sierra) or higher
Fully compatible with macOS 11.0 (Big Sur).

System Require­ments: macOS 10.12 (Sierra) or higher

(17484 kB, Built 06/17/2021)
de en fr 
Simon_4.3.1.zip

System Require­ments: OS X 10.10 (Yosemite) or higher
Fully compatible with macOS 10.14 (Mojave).

(16703 kB, Built 10/28/2018)
de en fr 
Simon_3.6.4.zip

System Require­ments: Mac OS X 10.6 (Snow Leopard) or higher

(12151 kB, Built 01/14/2015)

Softpedia Award FindMySoft Award

New in 5.0:
  • Please Note:
  • Simon 5 requires a minimum of macOS 10.12 (Sierra).
[More ...]
System Require­ments:
macOS 10.12 (Sierra) or higher