Caboodle 1.5Caboodle 1.5
Collect random snippets of text or images
Download
de en fr nl 
Caboodle_1.5.zip

System Require­ments: Mac OS X 10.6 (Snow Leopard) or higher Intel based CPU required.

(6381 kB, Built 05/04/2013)

Softpedia Award FindMySoft Award

New in 1.5:
  • The standard edition of the app is now signed with ...
  • Rebuilt for Mountain Lion using Xcode 4.
[More ...]
New in 1.4.1:
  • Restored support for Mac OS X 10.5 (Leopard), which was accidentally (and ...
  • French localization improved.
New in 1.4:
  • Fixes for Mac OS X 10.7 (Lion) compatibility.
  • Added full screen support on Lion.
[More ...]
System Require­ments:
Mac OS X 10.6 (Snow Leopard) or higher Intel based CPU required.