PDFClerk Pro 3.12.2PDFClerk Pro 3.12.2
PDF Editor / Powerful PDF Manipulation
Download
  de en fr 
PDFClerkPro_3.12.2.zip

System Require­ments: Mac OS X 10.6 (Snow Leopard) or higher
Not compatible with macOS 10.12 (Sierra).

System Require­ments: Mac OS X 10.6 (Snow Leopard) or higher

(15585 kB, Built 04/01/2014)
Mac OS X Universal
New in PDFClerk Pro 3.12.2:
  • Fix: Deleting pages that were recently moved could cause some ...
  • PDFClerk Pro is now Developer ID signed, to facilitate installation ...
New in PDFClerk Pro 3.12.1:
  • Fix: Opening PDF and PDFClerk Documents documents no longer marks ...
  • Fix: Fixed an intermittent crash that could occur when dragging ...
[More ...]
New in PDFClerk Pro 3.12:
  • New: On Mac OS X 10.6 (Snow Leopard), or higher, when a ...
  • Fix: Splitting pages while showing a box other than the ...
[More ...]
System Require­ments:
Mac OS X 10.6 (Snow Leopard) or higher