PDFClerk Pro 3.12.2PDFClerk Pro 3.12.2
PDF Editor / Powerful PDF Manipulation

PDFClerk Pro 3.12.2

PDFClerk Pro has reached its end of life and is no longer for sale. Please consider PDF Nomad instead. You can still download a copy of PDFClerk Pro if you need it.

Accelerate your PDF work with PDFClerk Pro

Whether you are a printing and graphic communication industry professional, need to prepare a PDF document to your print-shop's layout specifications or edit PDF documents for a wide variety purposes, chances are PDFClerk Pro can help you get the job done more easily.

PDF creation in the fast lane

  • Join PDF documents together;
  • Rearrange rotate, add and delete pages;
  • Split even and odd pages.
  • Impose multiple pages onto sheets (incl. Step and Repeat layouts);
  • Add and edit hyperlinks;
  • Add proofing/trimming marks;
  • Add text, graphics, watermarks, headers and footers;
  • Fill out forms (with custom fonts and styles).
  • Many More Features...

Create your own books, booklets and magazines easily

Now you can print out your manuals, reports, essays, articles, web pages, etc., in a convenient and economic way. You can even create books for languages that read from right to left like Arabic, Chinese and Hebrew.

Speed

PDFClerk Pro recalculates impositions blindingly fast. Even documents with thousands of pages are laid out in less than a second. Play with margin settings, or any other layout options: PDFClerk Pro's instant previews make it cheap to experiment.

New in PDFClerk Pro 3.12.2:
  • Fix: Deleting pages that were recently moved could cause some ...
  • PDFClerk Pro is now Developer ID signed, to facilitate installation ...
New in PDFClerk Pro 3.12.1:
  • Fix: Opening PDF and PDFClerk Documents documents no longer marks ...
  • Fix: Fixed an intermittent crash that could occur when dragging ...
[More ...]
New in PDFClerk Pro 3.12:
  • New: On Mac OS X 10.6 (Snow Leopard), or higher, when a ...
  • Fix: Splitting pages while showing a box other than the ...
[More ...]
System Require­ments:
Mac OS X 10.6 (Snow Leopard) or higher