MagicMacX 2.0MagicMacX 2.0
TOS Operating System for Mac OS X Computers
Requeri­mientos del Sistema:
Mac OS X 10.3 (Panther) o superior