Photolemur 1.0Photolemur 1.0
Photo Enhancement on Autopilot
Nyt i Photolemur 1.0:
  • Oprindelig udgivelse.
System­krav:
OS X 10.10.5 (Yosemite) eller senere