Software · Mac OS X · JobTimer 3.17

JobTimer 3.17
Calculate your job work time more easily – never lose a single second any more!
JobTimer 3.17

Order right now:

JobTimer 3.17
New Purchase
50% discount until Aug 01, 2014
was 29.00 EUR
now 14.50 EUR
net 12.18 EUR
 
JobTimer 3.17
Upgrade from version 1-2
50% discount until Aug 01, 2014
was 19.00 EUR
now 9.50 EUR
net 7.98 EUR
 
JobTimer 3.17
New Purchase (2 Licenses)
50% discount until Aug 01, 2014
was 46.40 EUR
now 23.20 EUR
net 19.50 EUR
 
JobTimer 3.17
New Purchase (3 Licenses)
50% discount until Aug 01, 2014
was 69.60 EUR
now 34.80 EUR
net 29.24 EUR
 
JobTimer 3.17
New Purchase (4 Licenses)
50% discount until Aug 01, 2014
was 92.80 EUR
now 46.40 EUR
net 38.99 EUR
 
JobTimer 3.17
New Purchase (5 Licenses)
50% discount until Aug 01, 2014
was 94.25 EUR
now 47.13 EUR
net 39.61 EUR
 
Shipping Costs
E-Mail this order to me! (I accept the legal notes from DSD.net and
understand that I cannot return email shipped software.)
was 11.90 EUR
now 0.00 EUR
 
I prefer the following software language (if possible):
Bold entries are required.
 
Company:
 
Name:
 
Street, No.:
 
ZIP, Town:
 
Country:
 
Email Address:
 
Newsletter:
 I want to get the free DSD.net Newsletter for Mac OS X (low traffic)!
 I want to get the free DSD.net Newsletter for Windows (low traffic)!
 
 
Phone:
 
Fax:
 
VAT reg.No.:
(For EC orders only:)
 
Payment Method:

(or with PayPal)
 
SEPA IBAN:
 
SEPA BIC:
 
Bank:
 
Credit Card:
 
CreditCard No.:
 
Card Check Number:
(see backside of card)
 
Expiry Date:
 
 
Additional Remarks:
Attention: This order will be processed by human beings, not by machines. Of course we do our best to proceed and ship your order as soon as possible. Please allow 24 – 48 hours response time from Monday to Friday, and somewhat longer on weekends. Thank you.

New in 3.17:
  • Application no longer crashes on launch (Mac OS X 10.5 ...
New in 3.16:
  • App icons support Retina displays.
  • All time values will be recalculated when a JobTimer document ...
[More ...]
New in 3.15:
  • Bugfix for old v1 documents.
Mac OS X 10.5 (Leopard) or higher.